Sunday, November 30, 2008

BlackBerry Device Software 4.5 for Sprint 8330

I recently purchased a BlackBerry Curve 8330 for Sprint. One of the must-have software packages for me is DataViz Documents To Go; which was recently released for the BlackBerry platform. But you need Device Software 4.5 or later. My Curve has 4.3.0.127.

There seems to be some confusion about the 4.5 software. It has been officially released for many of the current BlackBerry devices. My research shows that it has been released for some of the Curves, including the CDMA Curve for Verizon. I just can't seem to find the official Sprint edition.

Threads on some discussion forums indicates that any BlackBerry Curve 8330 can be upgraded with the multilingual release. Reading through these threads though, it seems like some of the carrier specific features, like No Force Roaming, aren't in the generic release. Go figure.

So I'll have to do some more poking around to figure out whether or not BlackBerry Device Software 4.5 is officially supported on Sprint's devices.

For the bold and the daring, there is a thread on SprintUsers.com that talks about loading over carriers version of 4.5 on your Sprint BlackBerry Curve 8330. With my BlackBerry kung-fu not as good as my Palm OS kung-fu, I'm not sure I'm ready to pull the trigger on an official unofficial upgrade just yet.

UPDATE 1:

I found this article on BlackBerryCool.com and they are reporting that OS 4.5 is official on Sprint, yet when I run the "Windows Update"-like upgrade checker at BlackBerry.com I get the message that my device is running the latest software; 4.3. Ugh!

UPDATE 2:

After a few hours of poking around on the Internet with Google and on the BlackBerry.com and Sprint.com websites, I have finally come to the conclusion that BlackBerry Device Software 4.5 is not (officially) available for the Sprint BlackBerry Curve 8330.

While searching for an answer, I stumbled across the BlackBerry Device Software v4.5 Availability page on the BlackBerry.com website. When I entered my device's PIN number, I received the following message:
"BlackBerry® Device Software v4.5 is not supported by your wireless service provider.

You will be redirected in 10 seconds to our Product Update form to receive notification when the software is available.

If you are not automatically taken to the form, please click here"

So, it seems that us BlackBerry Curve owners on Sprint who don't want to roll the dice with one of the unofficial upgrades still have to wait this out. I do hope that Sprint gets around to releasing the upgrade soon.
Post a Comment